Le ultime versioni di Joomla consento di effettuare l’aggiornamento del pacchetto joomla come se fosse un componente normale tramite “Cerca aggiornamenti”.
Molto spesso però ci viene visualizzato il seguente messaggio di errore:
L'impostazione PHP allow_url_fopen è disabilitata. Questa impostazione dev'essere abilitata perchè l'updater funzioni.

Questo messaggio è dovuto a impostazioni del server dove è ospitato il sito che volete aggiornare. Per ovviare a questo problema ci sono diverse soluzioni:

  • La prima è quella di impostare sul server il valore di allow_url_fopen = On chiedendo al vostro provider di effettuare questa modifica. Questa scelta non risulta spesso facile perché per questioni di sicurezza molti provider non la modificano.
  • La seconda opzione è di impostarla tramite il file .htaccess aggiungendo la seguente riga di codice: php_value allow_url_fopen On
  • La terza scelta ci si impone se le altre 2 indicate non hanno avuto esito positivo. Questa scelta è semplicemente quella di eseguire l’aggiornamento come nelle vecchie versioni di Joomla, cioè scaricare i pacchetti di aggiornamento e caricare i file sul server tramite un client FTP.